Wacom (non)compatibility with Catalina



  • Hello everyone! I am wondering if anyone else is struggling with their Wacom after updating to Catalina? In the desktop center, message "no device connected" continues to show, I have re-loaded driver several times, allowed security settings, nothing seems to help. This morning my pen kept dropping off, now after latest reload of driver, nothing is working, although I can scroll over to the wacom screen on my touchpad. Wacom is there, but not. I hope someone has figured this out! Thanks!!



  • Hi Cory! I was having different issues with my Wacom, and the solution I went with was to download an older version of the Wacom driver. I think I went back 2 versions and it still doesn't work perfectly, but it's better than before.


  • SVS OG

    @Cory-Leick I don't have a solution, but yes, I have had problems with my Cintiq and Mac from the beginning, 3-4 years now. They vary. I had the no connection problem and don't now, but don't remember what fixed it. While it was going on I would just keep reconnecting the cables and it all else failed, restart. Sorry! Then glitches do seem to have gotten worse with Catalina, but I'm not sure whether the problem is with PS, Catalina, or the driver. I'm so used to it by now that as long as the tablet is usable, I don't even do anything about it, because there are so very many variables, tech support trouble shooting takes so very long (I've lost up to a week of work before with no results), and I just want to keep working!

    Wish I had a better solution, but you're not alone! You may want to check out Wacom Reddit.



  • @aprilshin
    Thanks April, ...my troubles have now compounded, but I will try this, once I dig myself out of the tech hole I seem to have dug for myself! I appreciate your help!



  • @LauraA
    Thanks Laura!
    From what I have been able to glean, seems that the Catalina system update has a “much more robust” virus protection element to it, to the point where it will fight with any app not downloaded directly from the App Store. Which includes the Wacom drivers. Today I started my computer to find that it can no longer get on the internet, and somehow it has managed to hotspot like 88gigs from my phone, which has been running horribly for several days. And I have no idea what it was doing with all that data!! No more decent data for another month. Guess this may be my opportunity to spend some quality time with my traditional tools! Thanks again for your thoughts, I appreciate it!



  • Hi there

    There is solutions to this on youtube.

    Search fx Wacom driver Catalina

    Mic


  • SVS OG

    @Cory-Leick Just wanted to give you a heads up that I downloaded the PS update yesterday to see if it would help with other problems that were causing me to restart the computer repeatedly. The update caused such a mess that I had to step back to an earlier version of PS. In doing so I somehow lost my workspace and all my brushes, even though I knew how to drag the prefs folder back into the current folder. So then I spent another hour in tech support, ended up with prefs from three months ago, and still had to reload all the brushes. So I lost hours of work time yesterday and even now have an unworkably slow lasso tool, but don't want to spend another day in tech support. If reading this saves someone else the trouble I had yesterday, it's worth posting about it! I'd say Mac users should wait a while on the update.

    Apple has been a good bet for years, but by now I'm starting to wonder! Even if the problems are with PS or Wacom, a bit of coordination between platforms would be nice.



  • @LauraA Oh my goshhh that sounds terrible! Thank you for the heads up! Yeesh!



  • Also look here

    https://github.com/thenickdude/wacom-driver-fix

    Mic

    Works for me with Catalina 15.5



  • @micmac , thanks for this suggestion, which I think would be helpful to others experiencing issues. I did check out youtube advice a month or so ago, the post by Qiurious helped me (temporarily) then, and after seeing your post here, I re-visited that video and got my pen responding again! (Although cintiq buttons are useless). Thank you!!



  • @LauraA !
    That is AWFUL!
    I was lucky enough to not update before seeing this just now!!
    I was listening in on the livestream with Peter Brown, and tried updating my photoshop while this was going on, but update was going terribly slow and my phone was getting hot from trying to hotspot for all of this, so I cancelled the update. Then went to SVS to check on the forum, and found this post from you! So I consider myself very lucky in this moment, really appreciate the heads up! Sorry you had to deal with all of that, and yes, doesn't it seem like adobe/wacom could figure this out and save all of us from this endless frustration while we are still loyal?!! Thanks again!


  • SVS OG

    @Cory-Leick Yeah, as soon as I get a free day, I really need to look into some kind of more stable solution for all these problems. There are so many, though, and they vary so much, that it's like herding cats! I'm not 100% sure that you would have had all the same problems I did, but for me it actually rendered the set up unworkable. I looked for other reviews and advice, but didn't see anything yet. So it's possible it's just me! But I am suspicious of the fact that everything changed immediately.

    Once I have time to look into it, I'll let you know if I find anything that works.


  • SVS OG

    @micmac This looks interesting, but my Cintiq is newer, the driver the article lists is old and I am afraid to mess with command lines. I'll do the search, though!


  • SVS OG

    @micmac I followed your search terms, found this: https://www.youtube.com/watch?v=StejKvrCGT0

    I followed all the steps, including downloading and activating another app to open up the input menu option, and it helped a ton! It's not 100% glitch free, but the lasso tool is usable again! Woohoo! Thank you!



  • @Cory-Leick omg yes! I thought i was the only one that couldn't fix the issue. I can't remember which version of MacOS it was (it's been at least a year or so) but after updating, my Wacom screen would connect, touch would work but the pen wouldn't.. and the device wasn't even showing up in settings. I contacted Wacom support and it got escalated to the point where they were going to send me out a new one.. only i couldnt find the receipt and it probably wouldnt have helped anyway as it was clearly a driver issue. I'll try and dig up the document they sent me with steps on how to fully remove the software and reinstall it. Not that it fixed anything for me, but it seems to have done the trick for some people.
    I ended up getting an ipad pro and apple pencil and haven't looked back, though it would be nice to use my Cintiq again given how much it was 😭



  • @LauraA Thanks for posting that Youtube vid - it worked for me. My Wacom has been driving me insane since the Catalina update. Mac and Wacom don't seem to talk to each other and it makes for a huge amount of wasted time - infuriating. Thanks again! Jane



  • @LauraA
    Cool! This is exactly the same video I mentioned earlier that helped me! The guy that posted the video also replies to comments and was helpful.



  • @Kumica-Truong-0 I would be interested to know how to completely uninstall before re-installing- I tried looking at that last time before re-install, and I had like 400 Wacom/Cintiq items on my mac, and was too afraid to start weeding around in that! But I bet if I knew what was what, I would find at least some of that is fighting with each new installation attempt.
    So are you happy with the ipad and pencil comparatively? Are you able to do all the same things? Know I would miss the huge workspace (mine is 22" HD), and also feel that would be giving in to exactly what apple is wanting us to do, though I have seriously thought about ipad pro.


  • SVS OG

    @Cory-Leick Gee, I hadn't thought about the Apple "conspiracy" aspect! Hmmm...I have loved Apple products for years, but lately they are slowly eroding my enthusiasm with these updates that break everything else.

    And yes, I read the comments too! Very helpful!