Photoshop brush/eraser lag



  • I have a brand new RTX 2060 and can run games like Monster Hunter World and Anthem (I know Anthem has its own performance issues) just fine. I set Ps to use the GPU. I opened the task manager performance panel while working and the CPU spikes between 12-16%. GPU is spiking at 2%? I made the brush 500px and it lagged so hard during that test. I'm so confused. I can't upgrade my CPU right now. Too much $ and I'd like to get a new board at the same time because they're both a couple years old now.

    And I really don't want to switch my brush 😞 That's absurd if I can run a graphics heavy online video game but one brush stroke doesn't work. Is this a Windows 10/ Wacom/ Adobe issue?

    Captureperf.JPG
    Captureperf2.JPG



  • I missed that in the specs. I agree that when we can play games at 60+ fps it seems crazy to get brush lag during painting. Running a GTX 1070 myself and get similar issues.

    I happen to be playing with brushes today anyways and am watching Lee's video on the subject right now. He just mentioned that "high definition brushes with low spacing" cause the lag. It's right around 26:45 in the Photoshop Brushes class that he mentions it.

    It really should spike out the GPU if it's an information issue, but I have the same problems on Clip Studio Paint or Photoshop (so it's not just the software). Happens with my drawing tablet, or even the mouse on my PC. Happens on my Windows Ink laptop.

    The only common link I can determine is brush settings. Not sure why the bottleneck is there from a technical standpoint, but some brush settings just don't work right and need to be avoided.



  • @Lydia-M try downloading CPU-Z and GPU-Z free software for a detailed view of how your resources are being tested. You're better off upgrading your memory than graphics card. Photoshop doesn't really use the graphics card when drawing 2D - it's used in 3D rendering or illustrator uses the graphics card. Photoshop loves pumping the CPU and RAM. Use an SSD hard drive as a scratch disk for fast saves, the M.2 SSD drives are defo more reasonable now and save files in milliseconds. Make sure your scratch disk isn't the same disk that you launch the software from or you'll defo have performance problems. I have Crucial Vengeance LPX 32GB (3200 mhz) RAM. Best to use the fastest RAM your processor can handle. The i7 processor is great so I don't think that's the issue.

    Also, if you have a lot of layers going on then lots of memory is your best friend.


  • SVS Team SVS OG

    @Lydia-M drop your cache level down to 3 and push your memory up to like 65% and see if that helps.



  • This optimization page from Adobe might help. It's a pretty long list of things you can try to squeeze out extra performance. Photoshop does use the GPU for many features. It's getting better and better at utilizing them.

    I don't see it mentioned in there, but you may also try turning off smoothing on your brush. I've had that work with some, but not all, brushes that have bad performance.

    The important question is whether or not it's just certain brushes. If most brushes work and a few don't: I personally call that a brush issue. I usually just skip the custom brushes that lag. If the brush overpowers an i7, 24 gigs of RAM, SSD, and a GTX 1070, I'll just use another.

    If you REALLY love the brush then take the time to play with every setting (including the resolution of the "brush tip"/texture) and see if you can find what's causing the lag. Just hope that whatever it is doesn't "break" the brush.

    If all, or most, of your brushes are lagging then it's probably a performance or bug issue. There were some bugs with Wacom's and Windows 10 creators edition IIRC. Might want to Google those if it is a persistent issue across brushes.



  • Thanks for all the input on this. I tried changing some settings on my own and switched between the current version and an older version but I was still having the lag issues. Yesterday I went through a troubleshooting session with an Adobe rep via chat and screenshare. After all that I thought the problem was fixed but later it happened again - some strokes didn't appear and then it would all catch up after a few seconds. It's not happening as often but it's still a problem. The fact that all the performance settings were changed, and I can play video games without any issues, leads me to believe its something happening between Wacom, Windows Ink and Photoshop. Next I'm going to try troubleshooting with someone from Wacom. I'm also considering dumping Photoshop.



  • @Lydia-M I'm working with a Mac, but I had a really horrible lag as well. What ended up working for me was to turn off Rulers in Photoshop. That cleared everything up. Hope this helps.



  • @Lydia-M If it comes to that: Krita is free and I've heard it's pretty good. You can also try out Clip Studio Paint for free (I left PS and switched to CSP Pro a while back, they run 50% off sales fairly often).

    @kimwhit I never would have guessed to turn off rulers. What an odd bug.


  • SVS Team SVS OG

    @Lydia-M Turn off the Windows Ink and see if that helps. It could be the drivers fighting over each other.


  • SVS OG

    @Lydia-M I think you'd love Clip Studio I've been a Photoshop guy a long long time...but been really getting into Clip Studio and learning all the new stuff you can do with it and downloading a lot of nice brushes and reference. If I get use to coloring in it the only thing I'll even use Photoshop for setting up my files and exporting.



  • @SketchyArtish Seconding the Clip Studio love if you ditch PS. ❤



  • I'm going to try Clip Studio right now. This is what I've tried so far in Photoshop and despite everything I'm still getting brush lag + my document will stop responding when I switch tools and crash Photoshop. I also hate that when I use a small brush size my cursor gets circled and then it brings up a brush selection menu. I think that's Windows Ink doing that but I can't turn it off.

    Turned off rulers
    Turned off Windows Ink (when off it kills my brush tilt and the brush stroke looks bad so I have to leave it on)
    Turned off "Use GPU" was the weirdest change made by tech support
    Tech support also went through my preferences and changed lots of other things but I can't remember
    performance.JPG

    Update I also tried turning off Windows Ink and placing a PSUserConfig.txt file into a Photoshop settings folder so that my pen pressure would still work. The pen pressure works with Windows Ink turned off however it's laggy as heck so still not a solution for me.



  • @Lydia-M Sorry nothing seemed to work. You certainly made a thorough attempt at finding the issue! The transition from PS to CSP is not too bad. It has a lot of the same features. There are a few minor things they could do better, but overall I do enjoy it over PS for drawing. If you like it and are willing to wait, they do 50% off sales pretty often. I know they always do valentines day, which just passed, but I'm not sure when the next one will be.

    If you want a pile of custom brushes for a good price check out Frenden's Brush Pack. It's over 800 brushes for just $15. I will say that a few of them have lag, but with over 800 to choose from it's easy to skip a bad one here and there. You can also download free brushes, models, scenes, etc. inside the software which is really cool. Good luck!



  • Thanks for the info @SketchyArtish. I started the 30 day trial yesterday. I was happy with the speed but unhappy with the stock pastel brushes because they looked very digital. The Kyle pastel brush I always use in photoshop is a tall rectangle shape that tilts. I don't know if I'll be able to find or make something similar in clip studio 😞



  • @Lydia-M You can make a brush do just about anything in Clip Studio. Unfortunately, it looks like Kyle makes his brushes exclusively for Adobe so it's not possible to use his exact one. However, on twitter Kyle actually said this about the Frenden brushes I already recommended:

    Perhaps, but not for Clip Studio. @Frenden makes the best brushes on earth for that software, so I would be wasting my time.



  • After trying so many "fixes" and working with Adobe and Wacom tech support I finally have Photoshop working without any lag. I'm so happy. It was a combo of hardware and software issues. Here's what I did:

    • Plugged my Cintiq into my high performance graphics card with a DVI to DP adapter
    • Disabled my integrated Intel graphics card
    • Updated high performance card driver
    • Removed "All User Preferences" in the Wacom Tablet Preference File Utility
    • Reinstalled Wacom driver
    • Deleted AdobePhotoshopCC2019Prefs.psp from the Photoshop Settings folder
    • Deleted PSUserConfig.txt file from Photoshop Settings folder
    • Enabled Windows Ink

    Things that didn't work for me:

    • Turned off brush smoothing
    • Turned off rulers
    • Disabled Windows Ink and used PSUserConfig file to "trick" Photoshop
    • Disabled Use GPU in Photoshop Performance Settings

    😀


  • SVS Team SVS OG

    @Lydia-M I am glad you found a solution that worked!



  • Such great information, I like to take photos, it will be very useful to me!



  • Hi Lydia

    If you higher your spacing on your brush. this might work. hope that helps.1.jpg



  • @JerrySketchyArt I use CSP I am going to try those Frenden brushes now Thanks for the recommendation


Log in to reply